CVE-2017-7297

HIGH
8.8
CVSS Score
Published: March 29, 2017 at 12:00 AM UTC
Updated: June 17, 2026 at 01:24 AM UTC
1 product affected across 1 vendorRancher

Using N/A by N/A?

Get instant alerts when new vulnerabilities affect N/A - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 1%

Description

Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call. This is fixed in versions rancher/server:v1.2.4, rancher/server:v1.3.5, rancher/server:v1.4.3, and rancher/server:v1.5.3.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.2.0 ≤ v < 1.2.41.3.0 ≤ v < 1.3.51.4.0 ≤ v < 1.4.31.5.0 ≤ v < 1.5.3
Affected range stops below 1.2.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.3.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.4.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.5.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

References (2)

VDB Entryx_refsource_BIDThird Party Advisory
http://www.securityfocus.com/bid/97180
x_refsource_CONFIRMThird Party Advisory
https://github.com/rancher/rancher/issues/8296

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card