CVE-2017-6929

N/A
Published: March 1, 2018 at 10:00 PM UTC
Updated: June 17, 2026 at 01:23 AM UTC
2 products affected across 2 vendorsDebian LinuxDrupal

Using Drupal Core by Drupal.org?

Get instant alerts when new vulnerabilities affect Drupal Core - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
N/A
Exploit prediction
EPSS 1%

Description

A jQuery cross site scripting vulnerability is present when making Ajax requests to untrusted domains. This vulnerability is mitigated by the fact that it requires contributed or custom modules in order to exploit. For Drupal 8, this vulnerability was already fixed in Drupal 8.4.0 in the Drupal core upgrade to jQuery 3. For Drupal 7, it is fixed in the current release (Drupal 7.57) for jQuery 1.4.4 (the version that ships with Drupal 7 core) as well as for other newer versions of jQuery that might be used on the site, for example using the jQuery Update module.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

7 ≤ v < 7.577.0 ≤ v < 7.578.0.0 ≤ v < 8.4.0
Affected range stops below 7.57, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.4.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

Vendor Advisoryx_refsource_DEBIANThird Party Advisory
https://www.debian.org/security/2018/dsa-4123
x_refsource_CONFIRMMitigationVendor Advisory
https://www.drupal.org/sa-core-2018-001

CVSS

Confidentiality
NONE
Integrity
PARTIAL
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card