CVE-2017-5637

N/A
Published: October 10, 2017 at 01:00 AM UTC
Updated: June 17, 2026 at 01:20 AM UTC
2 products affected across 2 vendorsDebian LinuxZookeeper

Using Apache ZooKeeper by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache ZooKeeper - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
N/A
Exploit prediction
EPSS 73%

Description

Two four letter word commands "wchp/wchc" are CPU intensive and could cause spike of CPU utilization on Apache ZooKeeper server if abused, which leads to the server unable to serve legitimate client requests. Apache ZooKeeper thru version 3.4.9 and 3.5.2 suffer from this issue, fixed in 3.4.10, 3.5.3, and later.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

CVSS

Confidentiality
NONE
Integrity
NONE
Availability
PARTIAL
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-306CWE-400

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card