CVE-2017-3738

MEDIUM
5.9
CVSS Score
Published: December 7, 2017 at 04:00 PM UTC
Updated: June 17, 2026 at 01:18 AM UTC
3 products affected across 3 vendorsDebian LinuxOpenSSLNode.js

Using OpenSSL by OpenSSL Software Foundation?

Get instant alerts when new vulnerabilities affect OpenSSL - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.9
Exploit prediction
EPSS 13%

Description

There is an overflow bug in the AVX2 Montgomery multiplication procedure used in exponentiation with 1024-bit moduli. No EC algorithms are affected. Analysis suggests that attacks against RSA and DSA as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH1024 are considered just feasible, because most of the work necessary to deduce information about a private key may be performed offline. The amount of resources required for such an attack would be significant. However, for an attack on TLS to be meaningful, the server would have to share the DH1024 private key among multiple clients, which is no longer an option since CVE-2016-0701. This only affects processors that support the AVX2 but not ADX extensions like Intel Haswell (4th generation). Note: The impact from this issue is similar to CVE-2017-3736, CVE-2017-3732 and CVE-2015-3193. OpenSSL version 1.0.2-1.0.2m and 1.1.0-1.1.0g are affected. Fixed in OpenSSL 1.0.2n. Due to the low severity of this issue we are not issuing a new release of OpenSSL 1.1.0 at this time. The fix will be included in OpenSSL 1.1.0h when it becomes available. The fix is also available in commit e502cc86d in the OpenSSL git repository.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.0.0 ≤ v ≤ 4.1.24.2.0 ≤ v < 4.8.76.0.0 ≤ v ≤ 6.8.16.9.0 ≤ v < 6.12.28.0.0 ≤ v ≤ 8.8.18.9.0 ≤ v < 8.9.39.0.0 ≤ v < 9.2.1
Affected range stops below 4.8.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.12.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.9.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.2.1, so it looks safe — our inference, not a vendor statement

References (27)

VDB Entryx_refsource_BIDThird Party Advisory
http://www.securityfocus.com/bid/102118
VDB Entryx_refsource_SECTRACKThird Party Advisory
http://www.securitytracker.com/id/1039978
Vendor Advisoryx_refsource_REDHATThird Party Advisory
https://access.redhat.com/errata/RHSA-2018:0998
Vendor Advisoryx_refsource_REDHATThird Party Advisory
https://access.redhat.com/errata/RHSA-2018:2185

CVSS

Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-200

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card