CVE-2017-2297

N/A
Published: February 1, 2018 at 10:00 PM UTC
Updated: June 17, 2026 at 01:15 AM UTC
1 product affected across 1 vendorPuppet Enterprise

Using Puppet Enterprise by Puppet?

Get instant alerts when new vulnerabilities affect Puppet Enterprise - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
N/A
Exploit prediction
EPSS 0.6%

Description

Puppet Enterprise versions prior to 2016.4.5 and 2017.2.1 did not correctly authenticate users before returning labeled RBAC access tokens. This issue has been fixed in Puppet Enterprise 2016.4.5 and 2017.2.1. This only affects users with labeled tokens, which is not the default for tokens.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2016.4.52016.4 ≤ v < 2016.4.52016.5.12016.5.22017.1.02017.1.1
Affected range stops below 2016.4.5, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

x_refsource_CONFIRMVendor Advisory
https://puppet.com/security/cve/cve-2017-2297

CVSS

Confidentiality
PARTIAL
Integrity
PARTIAL
Availability
PARTIAL
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-287

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card