CVE-2017-20158

vova07 Yii2 FileAPI Widget UploadAction.php run cross site scripting

MEDIUM
6.1
CVSS Score
Published: December 31, 2022 at 10:00 AM UTC
Updated: June 17, 2026 at 01:15 AM UTC
2 products affected across 2 vendorsYII2 Fileapi WidgetYii2 FileAPI Widget

Using Yii2 FileAPI Widget by vova07?

Get instant alerts when new vulnerabilities affect Yii2 FileAPI Widget - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.6%

Description

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in vova07 Yii2 FileAPI Widget up to 0.1.8. It has been declared as problematic. Affected by this vulnerability is the function run of the file actions/UploadAction.php. The manipulation of the argument file leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.1.9 is able to address this issue. The identifier of the patch is c00d1e4fc912257fca1fce66d7a163bdbb4c8222. It is recommended to upgrade the affected component. The identifier VDB-217141 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.1.9
Affected range stops below 0.1.9, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card