CVE-2017-18037

N/A
Published: February 2, 2018 at 02:00 PM UTC
Updated: June 17, 2026 at 01:12 AM UTC
2 products affected across 1 vendorBitbucketBitbucket Server

Using Bitbucket Server by Atlassian?

Get instant alerts when new vulnerabilities affect Bitbucket Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
N/A
Exploit prediction
EPSS 1%

Description

The git repository tag rest resource in Atlassian Bitbucket Server from version 3.7.0 before 4.14.11 (the fixed version for 4.14.x), from version 5.0.0 before 5.0.9 (the fixed version for 5.0.x), from version 5.1.0 before 5.1.8 (the fixed version for 5.1.x), from version 5.2.0 before 5.2.6 (the fixed version for 5.2.x), from version 5.3.0 before 5.3.4 (the fixed version for 5.3.x), from version 5.4.0 before 5.4.2 (the fixed version for 5.4.x), from version 5.5.0 before 5.5.1 (the fixed version for 5.5.x) and before 5.6.0 allows remote attackers to read arbitrary files via a path traversal vulnerability through the name of a git tag.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

95%
3.7.0 ≤ v < 4.14.115.0.0 ≤ v < 5.0.95.1.0 ≤ v < 5.1.85.2.0 ≤ v < 5.2.65.3.0 ≤ v < 5.3.45.4.0 ≤ v < 5.4.25.5.05.5.25.5.35.5.45.5.55.5.6
Affected range stops below 4.14.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.0.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.1.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.2.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.3.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.2, so it looks safe — our inference, not a vendor statement
3.7.0 ≤ v < 4.14.115.0.0 ≤ v < 5.0.95.1.0 ≤ v < 5.1.85.2.0 ≤ v < 5.2.65.3.0 ≤ v < 5.3.45.4.0 ≤ v < 5.4.25.5.0 ≤ v < 5.5.1
Affected range stops below 4.14.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.0.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.1.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.2.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.3.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.5.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

x_refsource_CONFIRMVendor Advisory
https://jira.atlassian.com/browse/BSERV-10595

CVSS

Confidentiality
PARTIAL
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card