CVE-2017-12629

CRITICAL
9.8
CVSS Score
Published: October 14, 2017 at 09:00 PM UTC
Updated: June 17, 2026 at 01:03 AM UTC
6 products affected across 4 vendorsDebian LinuxUbuntu LinuxJBoss Enterprise Application Platform

Using Apache Solr before 7.1 with Apache Lucene before 7.1 by N/A?

Get instant alerts when new vulnerabilities affect Apache Solr before 7.1 with Apache Lucene before 7.1 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploit prediction
EPSS 92%

Description

Remote code execution occurs in Apache Solr before 7.1 with Apache Lucene before 7.1 by exploiting XXE in conjunction with use of a Config API add-listener command to reach the RunExecutableListener class. Elasticsearch, although it uses Lucene, is NOT vulnerable to this. Note that the XML external entity expansion vulnerability occurs in the XML Query Parser which is available, by default, for any query request with parameters deftype=xmlparser and can be exploited to upload malicious data to the /upload request handler or as Blind XXE using ftp wrapper in order to read arbitrary local files from the Solr server. Note also that the second vulnerability relates to remote code execution using the RunExecutableListener available on all affected versions of Solr.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

5.5.0 ≤ v ≤ 5.5.46.0.0 ≤ v ≤ 6.6.17.0.0 ≤ v ≤ 7.0.1lucene-solr ≤ v < 5.3.1-redhat-2lucene-solr ≤ v < 7.1.0lucene-solr
Affected range stops below 5.3.1-redhat-2, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.0, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in lucene-solr 7.2.0 (unaffected)
Vendor states this is fixed in lucene-solr 8.0.0 (unaffected)
redhat-enterprise-linux-server (environment)
lucene-solr ≤ v < 5.3.1-redhat-2lucene-solr ≤ v < 7.1.0lucene-solr
Affected range stops below 5.3.1-redhat-2, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.1.0, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in lucene-solr 7.2.0 (unaffected)
Vendor states this is fixed in lucene-solr 8.0.0 (unaffected)
All versions

References (24)

x_refsource_MISCMailing ListThird Party Advisory
http://openwall.com/lists/oss-security/2017/10/13/1
VDB Entryx_refsource_BIDThird Party Advisory
http://www.securityfocus.com/bid/101261
Vendor Advisoryx_refsource_REDHATThird Party Advisory
https://access.redhat.com/errata/RHSA-2017:3123
Vendor Advisoryx_refsource_REDHATThird Party Advisory
https://access.redhat.com/errata/RHSA-2017:3124
Vendor Advisoryx_refsource_REDHATThird Party Advisory
https://access.redhat.com/errata/RHSA-2017:3244
Vendor Advisoryx_refsource_REDHATThird Party Advisory
https://access.redhat.com/errata/RHSA-2017:3451
Vendor Advisoryx_refsource_REDHATThird Party Advisory
https://access.redhat.com/errata/RHSA-2017:3452

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-611

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card