CVE-2017-1000376

HIGH
7
CVSS Score
Published: June 19, 2017 at 04:00 PM UTC
Updated: June 17, 2026 at 12:59 AM UTC
6 products affected across 4 vendorsDebian LinuxEnterprise LinuxOpenshift

Using N/A by N/A?

Get instant alerts when new vulnerabilities affect N/A - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7
Exploit prediction
EPSS 0.5%

Description

libffi requests an executable stack allowing attackers to more easily trigger arbitrary code execution by overwriting the stack. Please note that libffi is used by a number of other libraries. It was previously stated that this affects libffi version 3.2.1 but this appears to be incorrect. libffi prior to version 3.1 on 32 bit x86 systems was vulnerable, and upstream is believed to have fixed this issue in version 3.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.2
Affected range stops below 3.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (4)

Vendor Advisoryx_refsource_DEBIANThird Party Advisory
http://www.debian.org/security/2017/dsa-3889
x_refsource_MISCMailing ListThird Party Advisory
https://www.qualys.com/2017/06/19/stack-clash/stack-clash.txt

CVSS

Attack Vector
LOCAL
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-119

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card