CVE-2013-10021

dd32 Debug Bar Plugin class-debug-bar-queries.php render cross site scripting

MEDIUM
6.1
CVSS Score
Published: March 11, 2023 at 08:31 PM UTC
Updated: June 16, 2026 at 11:50 PM UTC
2 products affected across 2 vendorsDebug BarDebug Bar

Using Debug Bar Plugin by dd32?

Get instant alerts when new vulnerabilities affect Debug Bar Plugin - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.6%

Description

A vulnerability was found in dd32 Debug Bar Plugin up to 0.8 on WordPress. It has been declared as problematic. Affected by this vulnerability is the function render of the file panels/class-debug-bar-queries.php. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.8.1 is able to address this issue. The patch is named 0842af8f8a556bc3e39b9ef758173b0a8a9ccbfc. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-222739.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Debug Bar· WordPresswordpress-plugin
95%
v < 0.8.1
Affected range stops below 0.8.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card