CVE-2012-10007

madgicweb BuddyStream Plugin ShareBox.php cross site scripting

MEDIUM
6.1
CVSS Score
Published: February 19, 2023 at 03:31 PM UTC
Updated: June 16, 2026 at 11:38 PM UTC
2 products affected across 2 vendorsBuddystreamProject Buddystream

Using BuddyStream Plugin by madgicweb?

Get instant alerts when new vulnerabilities affect BuddyStream Plugin - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.6%

Description

A vulnerability was found in madgicweb BuddyStream Plugin up to 3.2.7 on WordPress. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file ShareBox.php. The manipulation of the argument content/link/shares leads to cross site scripting. The attack can be launched remotely. Upgrading to version 3.2.8 is able to address this issue. The patch is named 7d5b9a89a27711aad76fd55ab4cc4185b545a1d0. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-221479.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.2.8
Affected range stops below 3.2.8, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card